Ошибка плохого интерпретатора при настройке virtualenv для python

Я пытаюсь настроить виртуальный env, но когда я пытаюсь его активировать, я получаю следующую ошибку:

virtualenv hello -bash: /usr/local/bin/virtualenv: /usr/local/Cellar/python/2.7.8/Frameworks/Python.framework/Versions/2.7/Resour: bad interpreter: No such file or directory 

Любые мысли о том, что может пойти не так? My $ PATH выглядит следующим образом:

 Users/me/workspace/google-cloud-sdk/bin:/usr/local/bin:/Users/me/workspace/google-cloud-sdk/bin:/urs/local/bin:/Users/me/workspace/google-cloud-sdk/bin:/urs/local/bin:/Users/me/workspace/google-cloud-sdk/bin:usr/local/python:usr/bin/python:/Library/Frameworks/Python.framework/Versions/2.7/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/texbin: No such file or directory 

– тот факт, что он возвращает ошибку, заставляет меня подозревать, что я как-то неправильно установил свой .bash_profile. Это единственные изменения, которые я сделал:

 #Set architecture flags export ARCHFLAGS="-arch x86_64" #Ensure user-installed binaries take precedence export PATH=/usr/local/bin:$PATH #Load .bashrc if it exists test -f ~/.bashrc && source ~/.bashrc # The next line updates PATH for the Google Cloud SDK. source '/Users/me/workspace/google-cloud-sdk/path.bash.inc' # The next line enables bash completion for gcloud. source '/Users/me/workspace/google-cloud-sdk/completion.bash.inc' 

И это мой .bashrc:

 # pip should only run if there is a virtualenv currently activated export PIP_REQUIRE_VIRTUALENV=true # cache pip-installed packages to avoid re-downloading export PIP_DOWNLOAD_CACHE=$HOME/.pip/cache 

2 Solutions collect form web for “Ошибка плохого интерпретатора при настройке virtualenv для python”

Я бы предложил вам пойти с virtualenv wrapper –

 export WORKON_HOME=$HOME/.virtualenvs export PROJECT_HOME=$HOME/Devel export VIRTUALENVWRAPPER_SCRIPT=/usr/local/bin/virtualenvwrapper.sh source /usr/local/bin/virtualenvwrapper_lazy.sh 

http://virtualenvwrapper.readthedocs.org/en/latest/install.html#quick-start

Похоже, эта проблема связана с несколькими версиями python, которые у меня были, некоторые из которых вызывали проблемы. Исправлена ​​проблема с установкой чистой ОС.

  • Как мне разработать и создать автономный пакет приложений PyGTK для MacOS с видными виджетами?
  • Как установить заголовки разработки Python на Mac OS X?
  • Как удалить Python 2.7 на Mac OS X 10.6.4?
  • Python3, lxml и «Symbol not found: _lzma_auto_decoder» в Mac OS X 10.9
  • Запись файла с помощью vim не запускает событие изменения файла в OS X
  • Портативный способ определения, может ли процесс перемещать / удалять файл?
  • Как добавить virtualenv в путь
  • Подсказка администратора GUI для Mac OS X Python
  • Раздражающее сообщение при открытии окон из Python на OS X 10.8
  • Как я могу взаимодействовать с приложением на mac через подпроцесс python?
  • Установка Python 2.5.2 на OS X 10.6
  • Python - лучший язык программирования в мире.