Какая версия BeautifulSoup работает с GAE (python 2.5)?

Когда я пишу

from BeautifulSoup import BeautifulSoup 

Я получаю следующую ошибку:

 No module named BeautifulSoup 

Все файлы сохраняются в папке проекта, вложенной папке BeautifulSoup. И он отлично работает, если BeautifulSoup.py помещается в ту же папку, где находится main.py.

One Solution collect form web for “Какая версия BeautifulSoup работает с GAE (python 2.5)?”

Если вы хотите включить BeautifulSoup из подпакета (подкаталог), убедитесь, что в каталоге есть файл __init__.py .

После этого from BeautifulSoup.BeautifulSoup import BeautifulSoup должен работать.

  • HttpError 401 «Login Required» при использовании Calendar v3 api python для вставки события
  • Ограничивает ли appengine-mapreduce операции?
  • Мигание флаговых сообщений не выполняется при переадресации
  • Ошибка urllib в Google App Engine и питоне. getaddrinfo не удалось
  • Файл загрузки google app engine python
  • Хороший способ генерировать GUID в приложении?
  • App Engine: вычисление размеров эскизов, которые будут созданы, используя миниатюры из blobstore
  • Невозможно запустить пользовательскую управляемую виртуальную машину Google App Engine: - должна быть задана ошибка в пользовательской точке
  • Python - лучший язык программирования в мире.