Использование Gensim показывает «Используется медленная версия gensim.models.doc2vec»

Я пытаюсь запустить программу, используя библиотеку Gensim на Python с версией 3.6.
Всякий раз, когда я запускал программу, я сталкивался с этими утверждениями:

C:\Python36\lib\site-packages\gensim-2.0.0-py3.6-win32.egg\gensim\utils.py:860: UserWarning: detected Windows; aliasing chunkize to chunkize_serial warnings.warn("detected Windows; aliasing chunkize to chunkize_serial") Slow version of gensim.models.doc2vec is being used 

Я не понимаю, что означает значение Slow version of gensim.models.doc2vec is being used . Как gensim выбирает медленную версию, и если я хочу самую быструю версию, то что мне нужно делать?

Проблема заключается в том, чтобы некоторые базовые пакеты не обновлялись. Сообщение Гордона помогло мне.

Но одним словом:

  1. Удалить Gensim

    sudo pip3 удалить gensim

  2. Установите python3-dev для сборки

    sudo apt-get install python3-dev build-essential

  3. Переустановите Gensim

    sudo pip3 install –upgrade gensim

Заметки:

  • Инструкции, приведенные выше, предназначены для систем, в которых pip и apt-get используются для управления пакетами

  • pip3 – это версия python3

Выделение комментария @ juanpa.arrivillaga, поскольку это помогло мне решить эту проблему.
Если вы установили anaconda:

  • удалить gensim: pip uninstall gensim
  • установите его с помощью менеджера пакетов anaconda: conda install gensim