Ядро IR, умирающее со свежей установкой Jupyter

Это мое оборудование

:~/Downloads$ lscpu Architecture: x86_64 CPU op-mode(s): 32-bit, 64-bit Byte Order: Little Endian CPU(s): 4 

Это моя ОС

 uname -a Linux 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux 

Это моя информация Jupyter

 Jupyter notebook. The version of the notebook server is 4.2.1 and is running on: Python 3.5.2 |Anaconda 4.1.1 (64-bit)| (default, Jul 2 2016, 17:53:06) [GCC 4.4.7 20120313 (Red Hat 4.4.7-1)] 

Я установил пакет R Essentials с помощью https://www.continuum.io/blog/developer/jupyter-and-conda-r

Но ИК-ядро умирает, как только я пытаюсь создать новый ноутбук R. Любой, кто использует Jupyter и R с решением?

Сообщения об ошибках

Ядро, похоже, умерло. Он перезапустится автоматически.

а также

Dead kernel

Ядро скончалось, и автоматический перезапуск завершился неудачно. Возможно, ядро ​​не может быть перезапущено. Если вы не можете перезапустить ядро, вы все равно сможете сохранить ноутбук, но текущий код больше не будет работать, пока ноутбук не будет снова открыт.

Мой вопрос Python отлично работает, но версия R умирает. Как использовать R из Jupyter

One Solution collect form web for “Ядро IR, умирающее со свежей установкой Jupyter”

Ваша проблема – проблема совместимости версий. В настоящий момент IRkernel не был обновлен до самой версии IPython / Jupyter. Если вы попытались установить de novo в R или RStudio:

 devtools::install_github('IRkernel/IRkernel') IRkernel::installspec(name = 'ir33', displayname = 'R 3.3') 

Или вы можете проверить следующее (эквивалентное выше) в R или RStudio:

 library(devtools) install_github('IRkernel/IRkernel') library(IRkernel) installspec(name = 'ir33', displayname = 'R 3.3') ##update your R version according to check which version of R you have R.version.string 

Появится сообщение об ошибке:

Jupyter или IPython 3.0 должен быть установлен, но не может запускать «jupyter», «ipython», «ipython2» или «ipython3».

Лучше всего здесь подождать обновления разработчиков. Надеюсь, они скоро разрешат проблему.

Если вам действительно нужно решить проблему в данный момент, вам необходимо установить исторические версии IPython и выполнить приведенную выше команду: Ссылка на IPython 3.x Series

  • Ошибка R_HOME с rpy2
  • rpy2, R и Ubuntu 12.04 - Недопустимая подстрока -fopenmp
  • Библиотека / инструмент для рисования тройных / треугольных графиков
  • проблемы с источником в файле .R в python с использованием rpy2
  • Python pandas наравне с группой R
  • Вызов сценария R из python с помощью rpy2
  • условные суммы для совокупности панд
  • Как импортировать сайт-пакет из rJython?
  • Python - лучший язык программирования в мире.