Установка Numpy под Ubuntu (12.04) вызывает Python ImportError

В Ubuntu (12.04) установлен python (2.7.5) с numpy (1.8rc2) с использованием openblas в собственную среду (/ din). Файл numpy site.cfg настроен для указания на openblas и скомпилирован как:

$ python setup.py build $ sudo python setup.py install --prefix=/home/Programs/din/local $ python Python 2.7.5 (default, Oct 24 2013, 15:33:08) [GCC 4.6.3] on linux2 Type "help", "copyright", "credits" or "license" for more information. >>> import numpy Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/home/Programs/din/local/lib/python2.7/site-packages/numpy/__init__.py", line 137, in <module> import add_newdocs File "/home/Programs/din/local/lib/python2.7/site-packages/numpy/add_newdocs.py", line 9, in <module> from numpy.lib import add_newdoc File "/home/Programs/din/local/lib/python2.7/site-packages/numpy/lib/__init__.py", line 4, in <module> from type_check import * File "/home/Programs/din/local/lib/python2.7/site-packages/numpy/lib/type_check.py", line 8, in <module> import numpy.core.numeric as _nx File "/home/Programs/din/local/lib/python2.7/site-packages/numpy/core/__init__.py", line 5, in <module> import multiarray ImportError: "/home/Programs/din/local/lib/python2.7/site-packages/numpy/core/multiarray.so: undefined symbol: ERR_peek_last_error 

Cython, gevent и другие пакеты python были успешно установлены в / din, но не numpy. Параметр $ PATH и python sys.path проверен, и все выглядит хорошо.

У кого-нибудь есть идеи попробовать?

One Solution collect form web for “Установка Numpy под Ubuntu (12.04) вызывает Python ImportError”

Это не может напрямую адресовать вашу конкретную проблему, но если вы используете Ubuntu 12.04, вы можете просто apt-get . Тогда, поскольку версия не будет последней, я тогда буду pip install --upgrade . Выполнение apt-get до apt-get как первое приложение, похоже, установит правильные зависимости; если сначала pip install , это не сработает.

В частности:

 sudo apt-get install python-numpy python-scipy libblas-dev liblapack-dev gfortran python-dev sudo pip install numpy --upgrade sudo pip install scipy --upgrade 
  • Поддержка python 2 в vim
  • Непризнанная проблема службы супервизора после установки
  • Не удалось импортировать MongoClient
  • ImportError: нет модуля с именем foxhound.utils.vis
  • Улучшение целостности скрипта CGI на Python, который создает учетные записи пользователей
  • пытается установить pymssql на ubuntu 12.04, используя pip
  • Включить PyROOT Ubuntu 14.04
  • Определите, запущен ли python в Ubuntu Linux
  • Как ограничить использование ядра python глобально в Ubuntu?
  • Как использовать numpy с OpenBLAS вместо Atlas в Ubuntu?
  • Импорт Orange возвращает «ImportError: no module named orange»
  • Python - лучший язык программирования в мире.