Невозможно выполнить pip virtualvv на Mac 10.9 Mavericks с заваренным питоном

Я пытаюсь настроить virtualenv чтобы мой python env чистым и организованным. Ну, на самом деле я пытаюсь установить scrapy как я написал здесь, где открылась эта возможность червей python, которую я сейчас пытаюсь очистить после того, как будет virtualenv .

Окончательный вердикт состоял в том, чтобы установить virtualenv (который не работает) и, следовательно, этот пост. Вот где я нахожусь:

 $ virtualenv test -bash: virtualenv: command not found 

Я понимаю, что это означает, что везде, где virtualenv устанавливается через pip install virtualenv не на моем пути, но это должно быть после следующих:

  1. Невозможно настроить pip virtualvv в OS X 10.8 с заваренным питоном 2.7

  2. http://hackercodex.com/guide/python-development-environment-on-mac-osx/

  3. https://github.com/Homebrew/homebrew/issues/12667#issuecomment-6257342

  4. http://www.lowindata.com/2013/installing-scientific-python-on-mac-os-x/

  5. Удалить все virtualenv и начать с нуля

brew doctor ready to brew .

Я предполагаю, что мой системный питон и мой пивоваренный питон не играют хорошо, но у меня нет идей относительно того, что еще я могу сделать, чтобы исправить это.

На данный момент я готов сделать чистую установку почти всего (даже mac os x), если это то, что нужно. Я почти уверен, что sudo pip install 'd что-то (ы) некоторое время назад, и я сейчас плачу за это.

Подробнее об установке:

 ~ ∮ pip install virtualenv Requirement already satisfied (use --upgrade to upgrade): virtualenv in /usr/local/lib/python2.7/site-packages Cleaning up... ~ ∮ pip install virtualenvwrapper Requirement already satisfied (use --upgrade to upgrade): virtualenvwrapper in /usr/local/lib/python2.7/site-packages Requirement already satisfied (use --upgrade to upgrade): virtualenv in /usr/local/lib/python2.7/site-packages (from virtualenvwrapper) Requirement already satisfied (use --upgrade to upgrade): virtualenv-clone in /usr/local/lib/python2.7/site-packages (from virtualenvwrapper) Requirement already satisfied (use --upgrade to upgrade): stevedore in /usr/local/lib/python2.7/site-packages (from virtualenvwrapper) Cleaning up... 

Я попробовал оба brew install python --with-brewed-openssl И brew install python --framework (после удаления предыдущего, когда он не работал) (и все другие предложения в приведенных выше ссылках)

заранее спасибо!