Установите py2exe для python 2.7 over pip: для этого пакета требуется Python 3.3 или новее

>>> python -c "import sys; print sys.version" 2.7.6 (default, Nov 10 2013, 19:24:18) [MSC v.1500 32 bit (Intel)] >>> pip --version pip 1.5.5 from C:\Python27\lib\site-packages (python 2.7) >>> pip install py2exe <mumble grumble..> RuntimeError: This package requires Python 3.3 or later 

хотя официальная страница загрузки py2exe говорит, что у них есть именно то, что мне нужно:

Скриншот

Итак, как установить py2exe через pip?

4 Solutions collect form web for “Установите py2exe для python 2.7 over pip: для этого пакета требуется Python 3.3 или новее”

Он отсутствует в pypi , если вы 0.6.9 ссылку 0.6.9 она 0.6.9 вас к 0.9.2.0 python 3, 0.9.2.0 , по-видимому, нет пакета 0.6.9 , доступного для загрузки.

Попробуйте использовать pip install http://sourceforge.net/projects/py2exe/files/latest/download?source=files

Существует также колесо py2exe доступное для Python 2.x: py2exe_py2 0.6.9

Вы можете сделать: pip install py2exe_py2

Pypi ссылка.

Вы можете попробовать использовать pip3. Или, если pip3 не установлен или не найден, попробуйте: python3 -m pip install py2exe .

Источник: https://superuser.com/a/942338/315157

вы можете напрямую скачать py2exe для python 2.7 отсюда

  • Python dict как создать ключ или добавить элемент к ключу?
  • Pandas обновляет выходные дни до ближайшего рабочего дня
  • Python -Remove Время из строки Datetime
  • Итерация над словарями с использованием циклов 'for'
  • sqlite3.ProgrammingError: Неправильное количество подключений
  • Python: matplotlib - функция массы вероятности как гистограмма
  • Ошибка локального компьютера IPython
  • изменение оператора ** на силовую функцию с помощью синтаксического анализа?
  • Python - лучший язык программирования в мире.