Помощник Pymacs не начинался через 30 секунд

Я видел другие вопросы по этому поводу, но на них никто не ответил, и никто из них не является моей проблемой.

У меня новая система, emacs 23.1, Centos 6.2 (я думаю). Я загрузил новейшие pymacs и установил его. Тем не менее, я получаю:

error: Pymacs helper did not start within 30 seconds 

Это с .emacs и .bashrc, которые всегда работали раньше. Кроме того, кажется, что когда я бегу от gnome, он находит помощника pymacs (но ropemacs не запускается), но в KDE (это то, что я на самом деле пытаюсь использовать). Он дает ошибку помощника pymacs.

РЕДАКТИРОВАНИЕ, потому что я нашел этот вопрос, когда у меня это было через несколько месяцев.

Теперь, я получаю ошибку помощника pymacs в gnome тоже. Я прокомментировал строку:

 (autoload 'python-mode "python-mode" "Python editing mode" ) 

Но это, похоже, не помогает. Это с новейшими пиратами.

AFAIK, эта ошибка возникает, если загружается старший pymacs.el. Проверьте, может ли это быть на вашем пути еще.

Если проблема не устранена, установите Pymacs в режиме python:

bzr branch lp: python-mode / components-python-mode

Автор Pymacs заявляет, что это проблема, связанная со старой версией python-mode.el которая загружает свою собственную копию Pymacs . Он предлагает два разных решения (см. Здесь ):

1) Комментируйте инициализацию python-mode (я думаю, что pymacs загружает его тогда)
2) Установите переменную py-load-pymacs-p на nil

Если я правильно помню, второе исправление не работает для моих emacs, но первое делает. Также может потребоваться обновить версию Pymacs , насколько я знаю, она теперь разработана на github, поэтому вы можете использовать версию, найденную в вышеупомянутом репо.