проблема с python pip с установкой требований.txt

В прошлом мне повезло с пипсом, но работа над установкой некоторых предметов в вену дала мне некоторые головные боли. Я продолжаю получать ошибки, например, не все дистрибутивы найдены для некоторого пакета. Хранение журнала отладки для отказа в /root/.pip/pip.log

Could not find any downloads that satisfy the requirement somepackage Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-RjqjFW/psycopg2 

Я знаю, что эти пакеты установлены в основной системе, но это похоже на то, что они не будут работать в Вене. Как вы все обошли эту проблему? Это был долгий день, и я просто не понимаю, в чем проблема, особенно потому, что они работают на моей локальной системе, они работают с основной установкой python на моей удаленной системе, но не в Вене по какой-то сумасшедшей причине. Есть идеи?

Вот требования, я думал, что это было довольно интенсивно для django, но это то, что pip freeze> requirements.txt дал мне

 Babel==1.3 Django==1.7.1 Fabric==1.10.1 Flask==0.10.1 Flask-Babel==0.9 Flask-Login==0.2.11 Flask-Mail==0.9.1 Flask-OpenID==1.2.4 Flask-SQLAlchemy==2.0 Flask-WTF==0.10.3 Flask-WhooshAlchemy==0.56 Jinja2==2.7.3 MarkupSafe==0.23 PAM==0.4.2 Pillow==2.3.0 Pygments==1.6 Scrapy==0.24.4 Sphinx==1.2.2 Tempita==0.5.2 WTForms==2.0.1 Werkzeug==0.9.6 Whoosh==2.6.0 adium-theme-ubuntu==0.3.4 apt-xapian-index==0.45 argparse==1.2.1 backports.ssl-match-hostname==3.4.0.2 blinker==1.3 boto==2.20.1 bottle==0.12.7 certifi==14.05.14 chardet==2.0.1 colorama==0.2.5 command-not-found==0.3 coverage==3.7.1 cssselect==0.9.1 debtagshw==0.1 decorator==3.4.0 defer==1.0.6 dirspec==13.10 docutils==0.11 duplicity==0.6.23 ecdsa==0.11 flipflop==1.0 guess-language==0.2 guppy==0.1.9 html5lib==0.999 httplib2==0.8 ipython==2.3.1 itsdangerous==0.24 lockfile==0.8 lxml==3.3.3 nose==1.3.4 numpy==1.8.2 oauthlib==0.6.1 oneconf==0.3.7 paramiko==1.15.2 pbr==0.10.7 pexpect==3.1 piston-mini-client==0.7.5 psycopg2==2.5.4 pyOpenSSL==0.13 pyasn1==0.1.7 pycrypto==2.6.1 pycups==1.9.66 pycurl==7.19.3 pygame==1.9.1release pygobject==3.12.0 pyserial==2.6 pysmbc==1.0.14.1 python-apt==0.9.3.5ubuntu1 python-debian==0.1.21-nmu2ubuntu2 python-openid==2.2.5 pytz==2014.10 pyxdg==0.25 queuelib==1.2.2 reportlab==3.0 requests==2.2.1 roman==2.0.0 sessioninstaller==0.0.0 simplegeneric==0.8.1 six==1.5.2 software-center-aptd-plugins==0.0.0 speaklater==1.3 sqlalchemy-migrate==0.9.2 sqlparse==0.1.14 system-service==0.1.6 tornado==4.0.2 unity-lens-photos==1.0 urllib3==1.7.1 virtualenv==1.11.6 w3lib==1.10.0 wsgiref==0.1.2 wxPython==2.8.12.1 wxPython-common==2.8.12.1 xdiagnose==3.6.3build2 z3c.xmlhttp==0.5.1 zope.interface==4.0.5 zope.publisher==4.0.0a4 zope.traversing==4.0.0 zope.viewlet==4.0.0a1 

  • Как добавить virtualenv в путь
  • Что такое virtualenv, и почему я должен использовать его?
  • virtualenv, который может найти перемещенные libraires (например, mysqlclient lib для MySQLdb)
  • Каковы эквиваленты Python для пакета Ruby's bundler / Perl?
  • Установить pycairo в virtualenv
  • Python, pinax, django, windows AttributeError: объект 'module' не имеет атрибута 'call_subprocess'
  • Как избежать «Разрешения отказа» при использовании pip с virtualenv
  • Почему `virtualenv` не может найти` pkg_resources`?
  • 3 Solutions collect form web for “проблема с python pip с установкой требований.txt”

    Я вижу несколько проблем:

    1. Ваш файл requirements.txt предназначен для базовой системы Python, а не для виртуальной среды. Django не имеет внешних зависимостей.

    2. Вы используете root-пользователя для установки пакетов в своей виртуальной среде (или вы используете sudo когда вам не следует).

    Лучший вариант – начать с нуля:

     $ virtualenv myvenv ... $ source myvenv/bin/activate (myvenv) $ pip install django ... (myvenv) $ pip freeze > requirements.txt 

    Если бы подобная проблема, но вышеупомянутый метод не сработал для меня. Уточнил его с помощью более простого решения:

    (venv) $ pip install --upgrade -r requirements.txt

    Это должно инициировать обновление и установку из файла requirements.txt

    У меня была эта проблема, но с другой причиной – у меня была старая версия virtualenv. Перед версией 1.7 вам нужно было указать параметр –no-site-packages при создании виртуальной среды, чтобы не включать глобальные пакеты.

    Два варианта исправить это, либо обновить virtualenv:

     sudo pip install virtualenv --upgrade virtualenv venv 

    Или используйте старый вариант без пакетов:

     virtualenv venv --no-site-packages 

    Это зафиксировало мой файл требований.txt.

    Python - лучший язык программирования в мире.