Tag: osx lion

Невозможно установить psycopg2 в virtualenv "error: stdarg.h: Нет такого файла или каталога"

ПРИМЕЧАНИЕ. Эта же ошибка возникает и при использовании easy_install, других способов установки … Я столкнулся почти с той же проблемой, что и я пытаюсь установить psycopg2 на Mac OS 10.6.3; он утверждает, что не может найти «stdarg.h», но я вижу, что он там; что мне делать? , за исключением того, что я на OSX Lion […]

Я хочу использовать matplotlib в osx lion

Я установил matplotlib из macports, а версия python – 2.7.1. $ sudo port install py27-matplotlib py27-matplotlib-basemap Я написал образец программы ниже. #!/usr/bin/python # -*- coding: utf-8 -*- from pylab import * plot([1,2,3]) show() Но это неправильно работает с журналом ошибок «no module pylab». И я попробовал easy_install. $ sudo easy_install matplotlib В этом случае моя […]

Ошибка сборки Python 2.5.6 на Mac Lion

Вот что я хотел бы сделать. Используйте web2py с MySQL. Для этого мне нужно использовать исходный web2py, а не web2py.app. Чтобы использовать web2py, мне нужен Python 2.5 У меня возникли проблемы с созданием и установкой Python 2.5 Я загрузил Python-2.5.6.tgz с страницы выпуска Python. Теперь я сделал ./configure а потом делать Затем я получаю следующую […]

Правильно Установка и настройка Python / Pyside / PyDev на OS X Lion (и, вероятно, будущие версии OS X)

У меня возникли проблемы с PyDev, которые не были автоматически завершены pyside, я подозреваю, что у меня отсутствует важный шаг в процессе установки. Итак, как установить и настроить новый OS X lion install для разработки pyside? Примечание. Этот вопрос НЕ принадлежит другому сайту стека. Это то, что программист должен сделать, чтобы получить свою машину в […]

Сообщение об ошибке для virtualenvwrapper на OS X Lion

Я использовал homebrew для установки python на новую установку Mac Lion и пытался установить virtualenv и virtualenvwrapper с помощью pip, но когда я начинаю новый сеанс терминала, я получаю эту трассировку: Traceback (most recent call last): File "<string>", line 1, in <module> ImportError: No module named virtualenvwrapper.hook_loader virtualenvwrapper.sh: There was a problem running the initialization […]

Как использовать libxml2 с python на osx lion?

Я на OSX Lion, и у меня установлен libxml2 (по умолчанию), и у меня установлен python (по умолчанию), но они не разговаривают друг с другом. Какой самый простой способ сделать эту работу на Lion? $ python -c "import libxml2" Traceback (most recent call last): File "<string>", line 1, in <module> ImportError: No module named libxml2

Использование модуля многопроцессорности python для ввода-вывода с pygame на Mac OS 10.7

Я использую pygame для запуска экспериментов в когнитивной науке, и часто у меня тяжелые требования ввода-вывода, поэтому мне нравится отбрасывать эти задачи для разделения процессов (при использовании многоядерной машины) для повышения производительности моего кода. Тем не менее, я столкнулся с сценарием, когда какой-то код работает на Linux-машине моего коллеги (Ubuntu LTS), но не на моем […]

Установка numpy Lion с Python 2.7?

Я работаю над OS X 10.7 с Python 2.7 с python.org и XCode 4.2. Следуя этим инструкциям , я попытался изменить переменные CC , FFLAGS и FFLAGS и установить с помощью sudo pip install numpy . Тем не менее, установка по-прежнему ищет gcc-4.2 . Я попытался установить gcc-4.2 через MacPorts, но получить эту Error: gcc42 […]

Ошибка при установке pylibmc using pip

Привет, когда я пытаюсь установить pylibmc на OSX Lion, используя pip, я получаю следующую ошибку: ./_pylibmcmodule.h:42:10: fatal error: 'libmemcached/memcached.h' file not found #include <libmemcached/memcached.h> ^ 1 error generated. error: command 'clang' failed with exit status 1 Какие-нибудь подсказки о том, как решить эту проблему?

Установка (сборка) matplotlib в mac osx lion

Я установил pynum и scipy (на osx Lion с python 2.7), но когда я попытался построить matplotlib git clone https://github.com/matplotlib/matplotlib.git cd matplotlib python setup.py build python setup.py install У меня эти ошибки: /System/Library/Frameworks/ApplicationServices.framework/Frameworks/ATS.framework/Headers/ATSTypes.h:242: error: declaration for parameter 'FMFontDirectoryFilter' but no such parameter src/_macosx.m:5912: error: expected '{' at end of input lipo: can't open input file: […]

Python - лучший язык программирования в мире.