Tag: osx

OS X Удалить установленный distutils проект

Я на El Capitan, и я хочу установить numpy с pip. Однако я получаю следующую ошибку: Detected a distutils installed project ('numpy') which we cannot uninstall. The metadata provided by distutils does not contain a list of files which have been installed, so pip does not know which files to uninstall. Существующая версия numpy выглядит […]

Python + OpenCV + py2app: numpy.core.multiarray не удалось импортировать

Окружающая среда: mac os x 10.7.5, xcode 4.2.1, python 2.7.5, opencv 2.4.7, py2app 0.7.3 Я пытаюсь упаковать простой скрипт python на основе opencv, используя py2app, но встроенное приложение вылетает с ошибкой, которая говорит об ошибке ImportError: numpy.core.multiarray failed to import вот скрипт python под названием demoApp.py import cv2 capture = cv2.VideoCapture(0) winName = 'eyeDetection' cv2.namedWindow(winName) […]

webbrowser.get («firefox») на Mac с Firefox «не смог найти исполняемый браузер»

Я думаю, что мне нужно знать, какую магическую командную строку или программу сценария OSA запускать, чтобы запустить URL-адрес в существующем браузере Firefox, если он работает, или запустить Firefox, если это не так. На Mac. Я тестирую программу Python (Crunchy Python), которая настраивает веб-сервер, а затем использует Firefox для интерфейса. Он запускает веб-приложение со следующим: try: […]

Почему установки python.org OS X построены с помощью gcc-4.0?

Отвечая на вопрос SO 3500638 , Нед Дейли заявляет, что поставляемые Apple Pythons (2.5.4 и 2.6.5) построены с помощью gcc-4.2. Однако все три python.org OS X Pythons (2.6.5, 2.7, 3.1.2) построены с использованием gcc-4.0. Вопросов Почему python.org Pythons (2.6.5, 2.7, 3.1.2) построен с использованием gcc-4.0? Каковы преимущества использования одного из python.org Pythons, построенного с помощью […]

Макросы Python на Mac с использованием Komodo

Я использую Komodo IDE, версию 6.1.1, build 61234, платформу macosx-x86. Я также использую Python 3.2 и Python 2.7. Я только что перешел к использованию (мой первый) Mac. Версия ОС 10.6.? На моих машинах Windows у меня было настроено несколько макросов, которые я хотел бы продолжать использовать: F2: сохранить файл, а затем запустить с помощью Python […]

обновить артист (Line2D) на фигуре без повторного рисования всей фигуры – сбрасывается axes.draw_artist ()

Я хочу, чтобы объект линии (Line2D) перемещался с текущей позицией курсора на нескольких осях фигуры. То, как я делаю это сейчас, – это перерисовать всю фигуру каждый раз, когда курсор перемещается, путем вызова fig.canvas.draw() Моя фигура состоит из 14 панелей, среди которых 10 имеет линию, которая должна перемещаться с помощью курсора, и делать это очень […]

Как сделать снимок экрана в Mac OS X изнутри Python: aka Command-Control-Shift-4

С Command-Control-Shift-4 область скриншота может быть взята / затем сохранена в буфер обмена. Интересно, будет ли подобное возможно изнутри Python. В идеале можно указать формат файла изображения, а также где можно сохранить его программно в Python. Есть идеи? отредактирован позже 1 Я applescript который делает почти то, что нужно, кроме того, что этот скрипт захватывает […]

Как изменить имя приложения в строке меню OSX в наборе приложений с чистым Python?

Я пытаюсь создать пакет приложений pure-Python для приложения wxPython. Я создал каталог .app с файлами, описанными в документах Apple, с файлом Info.plist и т. Д. Единственное отличие между «обычным» приложением и этим пакетом заключается в том, что точка входа (CFBundleExecutable) является скриптом, который начинается со следующего линия: #!/usr/bin/env python2.5 Все работает отлично, за исключением того, […]

MAC OS ImportError: pycurl: libcurl link-time version (7.37.1) старше, чем версия времени компиляции (7.43.0)

когда я импортирую curl в интерфейсе python, он отображает ошибку ImportError: pycurl: libcurl link-time version (7.37.1) is older than compile-time version (7.43.0). как его решить? моя система – йосемей.

Пигаме сломался?

Я использую pygame для AGES сейчас, и у меня никогда не возникала такая ошибка. Traceback (most recent call last): File "dodgeball.py", line 1, in <module> import pygame File "/Library/Python/2.7/site-packages/pygame/__init__.py", line 95, in <module> from pygame.base import * ImportError: dlopen(/Library/Python/2.7/site-packages/pygame/base.so, 2): Library not loaded: @executable_path/../Frameworks/SDL.framework/Versions/A/SDL Referenced from: /Library/Python/2.7/site-packages/pygame/base.so Reason: unsafe use of @executable_path in /Library/Python/2.7/site-packages/pygame/base.so with […]

Python - лучший язык программирования в мире.