Tag: pip

Python: программный запуск списка «pip»

Я пишу немного кода, который будет сообщать и сопоставлять различия между двумя установками python, управляемыми пипами. Как я могу программно получить информацию, предоставленную pip list без вызова подпрограммы вызова?

Безопасно ли использовать pip с git repo?

Можно использовать pip для установки из git repo с помощью команды pip install git+https://github.com/… но безопасно ли это для производственной среды? Есть ли способ защитить от его удаления без разветвления, размещения себя и слияния любых будущих обновлений?

"PermissionError: Разрешение отклонено: '/usr/lib/python3.5/site-packages'" установка Django

Я не могу установить базовые пакеты Django на Ubuntu. Я просто удалил virtualenv и переделал его. pip3install = pip3 install -r requirements.txt [mything] cchilders@cchilders-desktop:~/projects/mything (master) $ cat requirements.txt Django==1.10.1 django-filter djangorestframework psycopg2 twilio ipdb ipython [mything] cchilders@cchilders-desktop:~/projects/mything (master) $ pip3install Collecting Django==1.10.1 (from -r requirements.txt (line 1)) Using cached Django-1.10.1-py2.py3-none-any.whl Collecting django-filter (from -r requirements.txt […]

Как создать файл требований к файлам для tarball в локальной файловой системе?

Скажи мне, что то, что я пытаюсь сделать, не имеет смысла. Я хочу создать виртуальную среду, которая, среди прочего, включает MySQLDb 1.2.3. Эта библиотека распространяется как файл gzipped tarball (.tgz). Я хочу установить все, включая tarballs в моей локальной файловой системе, из файла требований в требования / apps.txt (это основано на настройке, которую я видел […]

Добавить требования к приложению к снимку докеры во время выполнения

Я хочу иметь возможность добавить дополнительные требования к собственному образу docker. Моя стратегия заключается в создании образа из файла docker с помощью команды CMD, которая будет выполнять команду «pip install -r» с использованием смонтированного тома во время выполнения. Это мой файл докеров: FROM ubuntu:14.04 RUN apt-get update RUN apt-get install -y python-pip python-dev build-essential RUN […]

Установка `numpy` в virtualenv в Ubuntu 11.10

Я получил следующие исключения при установке numpy с помощью easy_install numpy , может ли кто-нибудь помочь? Я использую pip или easy_install , у меня такие же проблемы. Трудно понять, что происходит не так. non-existing path in 'numpy/core': 'build/src.linux-x86_64-2.7/numpy/core/src/multiarray' non-existing path in 'numpy/core': 'build/src.linux-x86_64-2.7/numpy/core/src/umath' numpy/core/src/multiarray/scalartypes.c.src:2549:1: warning: 'longlong_arrtype_hash' defined but not used [-Wunused-function] numpy/core/src/multiarray/mapping.c:74:1: warning: '_array_ass_item' defined […]

pip или pip3 для установки пакетов для Python 3?

У меня есть Macbook с OS X El Captain. Я думаю, что на нем предустановлен Python 2.7 . Однако я также установил Python 3.5 . Когда я начал использовать Python 3 , я прочитал, что если я хочу установить пакет, я должен ввести: pip3 install some_package В любом случае, теперь, когда я использую pip install […]

Наличие пакета обновления python для обновления Ansible pip во время разработки

Я пишу некоторые Ansible пьесы, чтобы настроить python virtualenv, а также во время разработки, чтобы обновить пакет python и перезапустить сервер. У меня возникают проблемы с получением пакета обновления пакета. Мне все равно, как это делается, но я бы предпочел во время разработки просто добавить путь к пути python в virtualenv, а затем просто перезапустить […]

ImportError: нет модуля с именем «email.mime»; электронная почта не является пакетом

При запуске приведенного ниже кода я продолжаю получать ошибку: ImportError: No module named 'email.mime'; email is not a package Поэтому я запускаю: pip install email И получите следующую ошибку: ImportError: No module named 'cStringIO'… Command "python setup.py egg_info" failed with error code 1 Интернет сказал мне, чтобы я бежал: pip install –upgrade pip Чтобы решить […]

pip установить Django на python3.6

Если я запустил pip install Django я получаю Требование уже выполнено: Django в /usr/local/lib/python2.7/dist-packages Вместо этого я хотел бы использовать python3.6 (который уже установлен в /usr/bin/python3.6 ). Каков правильный синтаксис pip для установки последней версии Django на python 3.6?

 
Interesting Posts for Van-Lav

Python COM-сервер бросает «модуль», объект не имеет атрибута «VARIANT»

загрузить файл на сервер django с помощью curl

Как я могу создать мелодию? Есть ли звуковой модуль?

генерировать запрос на обновление с помощью django orm

В пандах могу ли я глубоко скопировать DataFrame, включая его индекс и столбец?

Ошибки памяти в Python Queues при вызове внутри потока

Какой самый питонический способ обеспечить, чтобы все элементы списка были разными?

HTTP-сервер Python отправляет ответ JSON

Как добавить строки в кадре данных pandas в цикле for?

Python openCV: пример kmeans не работает

Можно ли запускать срывное приспособление только после того, как все параметры запущены?

Как написать pandas dataframe для Vertica?

Использование якорей в regex python для получения точного соответствия

Тестирование библиотек Python C – получить путь сборки

Может ли Django работать только на Gunicorn (нет Apache или nginx)?

Python - лучший язык программирования в мире.