Tag: pip

Не удалось загрузить самую последнюю версию моего пакета из пипа

Недавно я начал использовать pypi для некоторой упаковки нескольких инструментов, которые полезны в моей повседневной жизни, но у меня возникают проблемы с тем, что я могу загрузить самую последнюю версию своего пакета. Этот пакет является pyfuzz и я просто pyfuzz до версии 0.1.1 , но по какой-то причине, когда я его устанавливаю, даже с флагом […]

Visual C ++ для python не удалось с статусом выхода 2 при установке divisi2

Я использую Python 2.7 на Windows 8.1 46 бит. Я хочу установить divisi2 https://pypi.python.org/pypi/Divisi2/2.2.5 Я установил NumPy и SciPy, которые являются предварительными условиями для divisi2. Я установил Visual C ++ для python 9.0. Всякий раз, когда я выдаю команду pip install divisi2, я получаю следующую ошибку в консоли. svdlib/svdwrapper.c(89) : error C2059: syntax error : […]

Как заморозить требования, которые не могут быть удовлетворены на местном уровне?

Я пишу приложение Python для развертывания на Heroku. В руководстве по Heroku мне нужно перечислить требования к пакетам в файле requirements.txt pip.txt. Руководство инструктирует меня локально устанавливать пакеты, а затем запускать pip freeze > requirements.txt для записи файла замороженных требований. Однако один из пакетов, которые я хочу использовать при развертывании на Heroku, не может быть […]

Как отменить Python setuptools – ошибка прокси-префикса

Когда я установил setuptools Python, я отсутствовал, решительно прикрепил к пути –prefix я использовал на другой машине: sh setuptools-0.6c11-py2.7.egg –prefix=/opt/python2.7.2 Теперь после этой ошибки, когда я пытаюсь установить pip я получаю следующую ошибку: [root @ kkdev src] # easy_install pip Поиск пункта Наилучшее совпадение: pip 1.0.2 Обработка pip-1.0.2-py2.7.egg pip 1.0.2 уже является активной версией в […]

Python3.3 не может найти libpython3.3m.so в linux (pip-3.3)

Я использую ubuntu 12.10 с python3.2 по умолчанию. Однако я загрузил python 3.3, так как его гораздо более полированный. Конечно, с тех пор у меня есть кошмар с установкой модулей для 3.3, так как пакеты python3 от synaptic устанавливаются до 3.2 dir. Итак, я установил pip с помощью python 3.3. Теперь у меня есть команда […]

pip не устанавливается в каталог сайтов-пакетов из virtualenv, когда я использую require.txt

Я относительно новичок в запуске Python с virtualenv, поэтому это может быть легко исправить, но я не могу для жизни понять, что происходит. Я запускаю Windows 7 Professional x64 с установленным Python 2.7.5. Я установил pip и virtualenv. У меня есть проект django, над которым я пытаюсь работать, на котором я клонировал из репозитория Heroku. […]

pip в соответствии с требованиями. txt

Я хочу установить statemodel, поэтому я запускаю sudo pip install –upgrade -r /srv/requirements.txt содержать требования .txt cat requirements.txt numpy==1.9.0 scipy==0.14.0 patsy==0.3.0 pandas==0.13.0 statsmodels==0.5.0 но похоже, что pip не устанавливает пакеты, перечисленные в файле requirements.txt, потому что я получаю ошибку зависимостей, например, «statsmodels required scipy» Есть ли способ сделать pip для установки пакетов в том порядке, […]

Как я могу установить конкретную версию pip через easy-install? – Mac OS Mavericks

Я постоянно получаю Cannot fetch index base URL https://pypi.python.org/simple/ всякий раз, когда я пытаюсь установить что-либо с самой последней версией pip. Я прочитал некоторые другие вопросы о том, что в своей последней версии проблема с SSL связана с проблемами, и рекомендуется установить pip 1.2.1. Как я могу установить определенную версию pip через easy_install?

Невозможно установить `pip` для` python 3.3`, но отлично работает для `python 2.7`

Я новичок в python, но не в программировании. Моя цель – изучить Django для веб-разработки. Я пытался установить более поздние версии python , pip и Django . Я мог бы установить pip для python 2.7 просто отлично, но теперь, когда я пытаюсь установить его на python 3 , он дает мне ошибку, которая, как я […]

pip: команда не найдена

Я столкнулся с проблемой при установке pip для python2.7. Я загрузил файл get-pip.py и успешно установил его: bogon:haha itensb$ python get-pip.py Requirement already up-to-date: pip in /Library/Python/2.7/site-packages Cleaning up… Но когда я запускаю команду, я получил: -bash: pip: command not found Я думаю, что это PATH не установлен соответствующим образом, но я новый на Mac. […]

Python - лучший язык программирования в мире.