Tag: pip

pip install -U steem error Windows Kits

Я все еще пытаюсь установить steem через команду «pip install -U steem». Я уже сделал то, что предложил Дэвид в этом потоке Ошибка протокола: требуется Microsoft Visual C ++ 14.0 , что означает, что я установил пакет Microsoft Visual, который он связал, и снова запустил команду установки. Ошибка, которую я получаю сейчас, следующая: creating build\lib.win-amd64-3.6\Crypto\Cipher […]

Python pip не создает зависимости во время установки

Пип, похоже, не создает зависимости от источника на моем сервере Ubuntu, хотя он всегда делает это на моей машине OS X. Например, когда я пытаюсь установить пакет qiime в среде conda или virtualenv (я попробовал обе), потребуется несколько секунд, чтобы установить множество вещей, которые требуют много времени для компиляции на моем Mac. (qiime)user@server:~$ pip install […]

Как установить и использовать MySQLdb для Python 3 в Windows 10?

Мои различные поиски, похоже, приходят с очень старыми сообщениями или упоминанием о том, как это сделать в cygwin. У меня был установлен python 3.5, а затем был установлен Anaconda3. У меня есть python 3.5 (Cpython), установленный в моем каталоге пользователя. Я попытался изменить порядок отображения вещей в моем пути переменных среды Windows, чтобы я мог […]

pyvenv устанавливает неправильную версию pip

Я создаю virtualenv с pyvenv env но версия установленного pyvenv env устарела. Я могу вручную обновить пипс в виртуальном env, но я бы хотел иметь правильную версию автоматически. Без активизации venv: ~> pip -V pip 7.1.2 from /usr/lib/python3.4/site-packages (python 3.4) Установка venv: ~> pyvenv env ~> source env/bin/activate.fish Когда активирован venv: ~> pip -V pip […]

Почему NumPy должен быть установлен через двоичный пакет?

Согласно документации NumPy : В большинстве случаев наилучшим способом установки NumPy в вашей системе является использование устанавливаемого двоичного пакета для вашей операционной системы. Но почему он не может быть установлен так же легко, как использовать pip ? Насколько я понимаю, NumPy необходимо скомпилировать что-то отличное от чистого Python в соответствии с целевой машиной. Как это […]

Нет модуля с именем «errors» mwclient

Продолжение на эту должность: веб-данные (wiki) scraping python @kwinkunks Помогло мне с вопросом. Однако я не могу импортировать mwclient. Это порождает эту ошибку: File "C:\Users\officeMediaIQ\Anaconda3\lib\site-packages\mwclient\__init__.py", line 26, in <module> from errors import * ImportError: Нет модуля с именем «errors» Спасибо за помощь

Apache + mod_wsgi – Python не загружает установленные модули

У меня есть сервер Apache с mod_wsgi, который запускает скрипт Python 2.7. Скрипт использует модуль Python Python, установленный через pip. Запуск сценария обычно с использованием python script.py работает нормально, но при запуске скрипта из wsgi – исключение ImportError выбрано для PIL. Это конфигурация Apache из /etc/apache2/sites-enabled/000-default.conf : <VirtualHost *:80> ServerAdmin webmaster@localhost DocumentRoot /var/www/ ErrorLog ${APACHE_LOG_DIR}/error.log […]

pip install – PermissionError: Разрешение отклонено

Окружающая среда Windows 8.1 Python 3.5 анаконда вопрос Когда я делаю pip install sklearn –upgrade , я получил следующую ошибку: Exception: Traceback (most recent call last): File "d:\anaconda3\lib\site-packages\pip\basecommand.py", line 209, in main status = self.run(options, args) File "d:\anaconda3\lib\site-packages\pip\commands\install.py", line 317, in run prefix=options.prefix_path, File "d:\anaconda3\lib\site-packages\pip\req\req_set.py", line 732, in install **kwargs File "d:\anaconda3\lib\site-packages\pip\req\req_install.py", line 835, in […]

Невозможно установить psycopg2 в virtualenv "error: stdarg.h: Нет такого файла или каталога"

ПРИМЕЧАНИЕ. Эта же ошибка возникает и при использовании easy_install, других способов установки … Я столкнулся почти с той же проблемой, что и я пытаюсь установить psycopg2 на Mac OS 10.6.3; он утверждает, что не может найти «stdarg.h», но я вижу, что он там; что мне делать? , за исключением того, что я на OSX Lion […]

Невозможно установить PyZMP для Python – Зависимости

У меня возникли проблемы с установкой зависимости PyZMP для iPython. Я пробовал несколько вещей, таких как использование pip / brew, но закончил установку пакета вручную, используя этот ответ . Теперь pip list packages дают следующие pyzmq (14.2.0-dev) pyzmq-static (2.2) (Я также пытался использовать pyzmq-static). Кроме того, мои яйца питона явно присутствуют в правильном месте: ls […]

Python - лучший язык программирования в мире.