Tag: pip

Невозможно установить / обновить пакеты с помощью python-pip (« Not a directory»)

Недавно я установил новую машину (Acer Chromebook C720P – используя Ubuntu). Все работает отлично, я установил Pycharm, Mercurial … и так далее. Я установил несколько пакетов, используя pip, все было в порядке. Я запускаю проект Pycharm, хорошо. На следующий день больше ничего не работает. Пип дает мне следующее: (Python3.4p)dl@dl-Peppy:~/Python3.4p$ sudo pip install –upgrade pip The […]

Передавать пользовательские флаги CMake в pip при создании модуля, который требует скомпилированного кода

В настоящее время я устанавливаю модуль, который требует скомпилированного кода (dlib) с помощью pip. Pip запускает setup.py, который запускает cmake и соответствует коду. Есть ли способ передать пользовательские флаги cmake в pip при указании модуля для установки или мой единственный вариант запустить cmake вручную? Я не мог найти много об этом поиске.

Установлен ли python.org установщик python с пипсом и как его использовать?

Я могу загрузить python 2.7.12 с python.org, и все версии python с версии 2.7.9 должны поставляться вместе с пипсом, но после его установки использование pip в терминале не работает. Я нахожусь на macOS. Установил ли я пип, и если да, то как его использовать?

Установка пипа в Pycharm 2016.3

Я перешел на новую версию Pycharm. В терминале он говорит bash-3.2$ вместо моего имени пользователя. Когда я попытался установить библиотеку, он сказал, что команда pip не найдена: bash: pip: command not found Поэтому я установил pip: bash-3.2$ sudo easy_install pip Searching for pip Best match: pip 8.1.2 pip 8.1.2 is already the active version in […]

Ошибка установки Tensorflow в Windows 7

Я как раз собираюсь установить shadoworflow в среду Anaconda, но у меня есть некоторые проблемы. Как только я поставлю следующую команду pip install –ignore-installed –upgrade https://storage.googleapis.com/tensorflow/windows/gpu/tensorflow_gpu-1.0.0-cp35-cp35m-win_x86_64.whl Я получаю сообщение об ошибке: tensorflow_gpu_1.0.0-cp35-cp35m-win_x86_64.whl не поддерживает колесо на этой платформе. Затем я обновил pip этой командой: pip install –upgrade pip Но ничего не случилось. У меня есть […]

Python: нет модуля с именем sphinx error

Я следовал следующему руководству . $ pip install sphinx sphinx-autobuild $ pip freeze | grep "sphinx" sphinx-autobuild==0.6.0 sphinxcontrib-websupport==1.0.0 $ cd docs $ sphinx-quickstart $ make html make html дает следующую ошибку: /Library/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python: No module named sphinx make: *** [help] Error 1 [Q] Как я могу предотвратить эту ошибку? Спасибо за ваше драгоценное время и помощь.

Ошибка в дате регистрации

Пока я пытался установить пакет python «datefinder», я встретил ошибку в регулярном выражении и визуальном c ++. Я просмотрел множество сообщений Stackoverflow и пока не могу найти решение. Одно сообщение похоже, но ответа не получено. Любые комментарии оцениваются! C:\Users\sheldonc\Downloads>pip install datefinder-0.6.1-py2.py3-none-any.whl Processing c:\users\sheldonc\downloads\datefinder-0.6.1-py2.py3-none-any.whl Requirement already satisfied: python-dateutil>=2.4.2 in c:\users\sheldonc\appdata\local\programs\python\python36-32\lib\site-packages (from datefinder==0.6.1) Collecting regex==2016.01.10 (from datefinder==0.6.1) […]

Ошибка формата при использовании pip install -e из GitHub. Значение использования #egg?

Следующие работы: pip install git+git://github.com/pydata/pandas@master Но следующее: pip install -e git+git://github.com/pydata/pandas@master Ошибка: –editable=git+git://github.com/pydata/pandas@master is not the right format; it must have #egg=Package Зачем? Кроме того, я читал, что -e делает следующее: –egg Install as self contained egg file, like easy_install does. Какова ценность этого? Когда это будет полезно? (Я всегда работаю на virtualenv и устанавливаю […]

Как мне получить pip для установки определенной версии meld?

Пытаясь следовать этому руководству https://rayed.com/wordpress/?p=1496, я пытаюсь заставить супервизора генерировать его файл conf, но он терпит неудачу, потому что ему требуется meld3> = 0.6.5 и, по-видимому, meld3 1.0.2 не учитывается. Попробовав различные решения на https://github.com/puphpet/puphpet/issues/1492, я хочу следовать предложению pbylina о понижении до meld3 1.0.0, но, в отличие от pbylina, я получаю ошибки, когда пытаюсь […]

Нет модуля с названием упаковки

Я работаю над Ubuntu 14. Я устанавливаю python3 и pip3. Когда я пытаюсь использовать pip3, у меня есть эта ошибка Traceback (most recent call last): File "/usr/local/bin/pip3", line 6, in <module> from pkg_resources import load_entry_point File "/usr/local/lib/python3.5/dist-packages/pkg_resources/__init__.py", line 70, i n <module> import packaging.version ImportError: No module named 'packaging' Кто-нибудь знает, в чем проблема? Большое […]

Python - лучший язык программирования в мире.