Tag: pip

Можно ли использовать pip для установки пакета из частного репозитория github?

Как видно из названия, я пытаюсь установить пакет python из частного репозитория github. Для публичного репозитория я могу выполнить следующую команду, которая отлично работает: pip install git+git://github.com/django/django.git Однако, если я попробую это для частного репозитория: pip install git+git://github.com/echweb/echweb-utils.git Я получаю следующий вывод: Downloading/unpacking git+git://github.com/echweb/echweb-utils.git Cloning Git repository git://github.com/echweb/echweb-utils.git to /var/folders/cB/cB85g9P7HM4jcPn7nrvWRU+++TI/-Tmp-/pip-VRsIoo-build Complete output from command /usr/local/bin/git […]

Что такое virtualenv, и почему я должен использовать его?

Я пытаюсь установить пакет Python с этой командой pip install <name of package> Я получаю ошибки разрешения, и я не уверен, почему. Я мог бы запустить его с помощью sudo , но кто-то сказал мне, что это плохая идея, и вместо этого я должен использовать virtualenv. Что такое виртуальный? Что он делает для меня?

`pip install pandas` дает UnicodeDecodeError: кодек ascii не может декодировать байт 0xe2 в позиции 41: порядковый номер не в диапазоне (128)

При выполнении UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 41: ordinal not in range(128) капли Digital Ocean 512MB я получаю ошибку UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 41: ordinal not in range(128) . Любые идеи, что могло вызвать это? Я запускаю Ubuntu 12.04 64bit. [Полная ошибка]

Как изменить местоположение установки по умолчанию для pip

Я пытаюсь установить Pandas, используя pip, но у меня проблемы. Я просто запускал sudo pip install pandas который успешно загружал панды. Однако он не загрузился в место, которое я хотел. Вот что я вижу, когда я использую pip show pandas : — Name: pandas Version: 0.14.0 Location: /Library/Python/2.7/site-packages/pandas-0.14.0-py2.7-macosx-10.9-intel.egg Requires: python-dateutil, pytz, numpy Поэтому он установлен. […]

requirements.txt в зависимости от версии python

Я пытаюсь перенести пакет python2 на python3 (не мой собственный), используя шесть, чтобы он совместим с обоими. Однако один из пакетов, перечисленных в файле требований.txt, теперь включен в stdlib python3, а версия pypi не работает в python3, поэтому я хочу условно исключить его. Делать это в setup.py легко, я могу просто сделать что-то вроде: if […]

Python PIP Install throws TypeError: неподдерживаемый тип операндов для – =: 'Retry' и 'int'

Используя pip install для любого модуля, очевидно, на моей системе Ubuntu 16.04 с python 2.7.11+ выдает эту ошибку: TypeError: unsupported operand type(s) for -=: 'Retry' and 'int' Что не так с пипсом? Как я могу переустановить его, если это необходимо? Обновление: полная трассировка ниже sunny@sunny:~$ pip install requests Collecting requests Exception: Traceback (most recent call […]

pip не удается установить пакеты из требования .txt

Я пытаюсь установить программное обеспечение python, используя файл требований. >> cat requirements.txt Cython==0.15.1 numpy==1.6.1 distribute==0.6.24 logilab-astng==0.23.1logilab-common==0.57.1 netaddr==0.7.6 numexpr==2.0.1 ply==2.5 pycallgraph==0.5.1 pyflowtools==0.3.4.1 pylint==0.25.1 tables==2.3.1 wsgiref==0.1.2 Поэтому я создаю виртуальную среду >> mkvirtualenv parser (parser) >> pip freeze distribute==0.6.24 wsgiref==0.1.2 (parser) >> pip install -r requirements.txt … а затем я загружаю пакеты, но не установлен с ошибками: […]

pip не может правильно установить пакеты: Permission denied error

Я пытаюсь установить lxml для установки scrapy на моем Mac (v 10.9.4) ╭─ishaantaylor@Ishaans-MacBook-Pro.local ~ ╰─➤ pip install lxml Downloading/unpacking lxml Downloading lxml-3.4.0.tar.gz (3.5MB): 3.5MB downloaded Running setup.py (path:/private/var/folders/8l/t7tcq67d34v7qq_4hp3s1dm80000gn/T/pip_build_ishaantaylor/lxml/setup.py) egg_info for package lxml /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'bugtrack_url' warnings.warn(msg) Building lxml version 3.4.0. Building without Cython. Using build configuration of libxslt 1.1.28 warning: no previously-included […]

Поставка аргументов numpy site.cfg в pip

Я использую NumPy, встроенный в библиотеку ядра Math. Я использую virtualenv и обычно использую pip для установки пакетов. Однако, чтобы NumPy обнаружил библиотеки MKL, необходимо создать файл site.cfg в исходном каталоге NumPy перед его компиляцией, а затем вручную создать и установить. Я мог бы написать весь этот процесс, но я надеялся на более простое решение. […]

Почему pip freeze сообщает о некоторых пакетах в новом virtualenv, созданном с -no-site-пакетами?

Когда я создаю новый virtualenv, pip freeze показывает, что у меня есть несколько пакетов, даже если я ничего не установил в среде. Я ожидал, что pip freeze вернет пустой вывод до тех пор, пока мой первый pip install в среду. wsgiref является частью стандартной библиотеки , не так ли, поэтому почему она вообще появляется? день […]

Python - лучший язык программирования в мире.