Tag: pip

Могу ли я заставить pip переустановить текущую версию?

Я сталкивался с ситуациями, когда текущая версия пакета кажется неработоспособной и требует переустановки. Но pip install -U не коснется пакета, который уже обновлен. Я вижу, как принудительно переустановить, сначала удаляя (с pip uninstall ), а затем устанавливая, но есть ли способ просто принудительно «обновить» номинально текущую версию за один шаг?

ImportError: невозможно импортировать имя HTTPSHandler с помощью PIP

Опираясь на ошибку HTTPSHandler при установке пакетов python с помощью pip, следующая трассировка стека, ——–desktop:~$ pip install Django==1.3 Traceback (most recent call last): File "/home/env/.genv/bin/pip", line 9, in <module> load_entry_point('pip==1.4.1', 'console_scripts', 'pip')() File "/home/env/.genv/lib/python2.7/site-packages/pkg_resources.py", line 378, in load_entry_point return get_distribution(dist).load_entry_point(group, name) File "/home/env/.genv/lib/python2.7/site-packages/pkg_resources.py", line 2566, in load_entry_point return ep.load() File "/home/env/.genv/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load […]

Не удалось найти версию, удовлетворяющую требованию pytz

У меня проблема с установкой pytz в virtualenv. Downloading/unpacking pytz Could not find a version that satisfies the requirement pytz (from versions: 2009r, 2008b, 2009f, 2008c, 2007g, 2011g, 2005m, 2011e, 2007f, 2011k, 2007k, 2006j, 2008h, 2008i, 2011e, 2008a, 2009e, 2006g, 2011j, 2010l, 2005m, 2008i, 2005k, 2008g, 2007c, 2007i, 2009l, 2009r, 2006j, 2011k, 2007d, 2006p, 2009i, […]

ImportError после успешной установки

Я успешно установил библиотеку с pip install <library-name> . Но когда я пытаюсь импортировать его, python вызывает ImportError: No module named <library-name> . Почему я получаю эту ошибку и как я могу использовать установленную библиотеку?

Ошибка установки python pip psycopg2

Я pip install psycopg2 на Mac. Он установлен отлично, но когда я пытаюсь использовать psycopg2, я получаю ошибку: Reason: Incompatible library version: _psycopg.so requires version 1.0.0 or later, but libssl.0.9.8.dylib provides version 0.9.8 pip freeze показывает psycopg2==2.4.5 раз. Я установил psycopg2 на несколько virtualenvs, но это первый раз, когда я вижу такую ​​ошибку. Я попытался […]

ubuntu 14.04, pip не может обновить matplotllib

Когда я пытаюсь обновить свой matplotlib с помощью pip, он выводит: Downloading/unpacking matplotlib from https://pypi.python.org/packages/source/m/matplotlib/matplotlib-1.4.0.tar.gz#md5=1daf7f2123d94745feac1a30b210940c Downloading matplotlib-1.4.0.tar.gz (51.2MB): 51.2MB downloaded Running setup.py (path:/tmp/pip_build_root/matplotlib/setup.py) egg_info for package matplotlib ============================================================================ Edit setup.cfg to change the build options BUILDING MATPLOTLIB matplotlib: yes [1.4.0] python: yes [2.7.6 (default, Mar 22 2014, 22:59:38) [GCC 4.8.2]] platform: yes [linux2] REQUIRED DEPENDENCIES […]

Обновление python в virtualenv

Есть ли способ обновить версию python, используемую в virtualenv (например, если выпущена версия bugfix)? Я мог бы pip freeze –local > requirements.txt затем удалить каталог и pip install -r requirements.txt но для этого требуется большая переустановка больших библиотек, например numpy, которые я использую много. Я вижу, что это преимущество при обновлении, например, 2.6 -> 2.7, […]

Как обновить сам пипс внутри моей виртуальной среды?

Я могу обновить пакеты с управляемыми пакетами, но как я могу обновить сам протокол? Согласно pip –version , в настоящее время у меня есть pip 1.1, установленный в моем virtualenv, и я хочу обновить его до последней версии. Какая команда для этого? Нужно ли использовать дистрибутив или есть ли команда native pip или virtualenv? Я […]

Неустранимая ошибка в пусковой установке: невозможно создать процесс с помощью «C: \ Program Files (x86) \ Python33 \ python.exe» «C: \ Program Files (x86) \ Python33 \ pip.exe" "

Поиск в сети кажется проблемой, вызванной пробелами в пути установки Python. Как мне заставить работать на ПК без переустановки всего в пути без пробелов?

pip в глобальных пакетах сайтов вместо virtualenv

Использование pip для установки пакета в virtualenv заставляет пакет устанавливаться в папке глобальных пакетов сайтов, а не в папке virtualenv. Вот как я установил Python3 и virtualenv на OS X Mavericks (10.9.1): Я установил python3 с помощью Homebrew: ruby -e "$(curl -fsSL https://raw.github.com/Homebrew/homebrew/go/install)" brew install python3 –with-brewed-openssl Изменена $PATH в .bash_profile; добавлена ​​следующая строка: export […]

Python - лучший язык программирования в мире.