Tag: pip

Почему pip устанавливает matplotlib версии 0.91.1, когда PyPi показывает версию 1.0.0?

Обновление 15 октября 2012 г. PyPi теперь показывает matplotlib на 1.1.0, поэтому этот вопрос решен. Установите matplotlib через: pip install matplotlib Устаревшая информация ниже PyPi показывает matplotlib 1.0.0 . Однако, когда я устанавливаю matplotlib через pip в virtualenv , устанавливается версия 0.91.1. Почему разница в версиях? Есть ли способ установить install matplotlib 1.0.0? Исследование Похоже, […]

Может ли пакет Python зависеть от конкретной версии управления версиями другого пакета Python?

Некоторые полезные пакеты Python разбиваются на pypi, и единственной приемлемой версией является конкретная ревизия в системе контроля версий. Может ли это быть выражено в setup.py например requires = 'svn://example.org/useful.package/trunk@1234' ?

pip игнорирует dependency_links в setup.py

У меня есть dependency_links в моей setup.py: … dependency_links = ['http://github.com/robot-republic/python-s3/tarball/master.tar.gz#egg=python-s3'], … Но это не сработает. Однако install_requires работает нормально. Может быть, есть еще один способ настройки git repo, как требуется для setup.py?

Не удалось найти версию, удовлетворяющую требованию <package>

Я устанавливаю несколько пакетов Python в Ubuntu 12.04, используя следующий файл requirements.txt Txt: numpy>=1.8.2,<2.0.0 matplotlib>=1.3.1,<2.0.0 scipy>=0.14.0,<1.0.0 astroML>=0.2,<1.0 scikit-learn>=0.14.1,<1.0.0 rpy2>=2.4.3,<3.0.0 и эти две команды: $ pip install –download=/tmp -r requirements.txt $ pip install –user –no-index –find-links=/tmp -r requirements.txt (первый загружает пакеты, а второй устанавливает их). Процесс часто останавливается с ошибкой: Could not find a version that […]

Могут ли устанавливать установки PP, не указанные в setup.py во время установки?

Я бы хотел, чтобы pip установил зависимость, которая у меня есть на GitHub, когда пользователь выдает команду на установку оригинального программного обеспечения, также из источника на GitHub. Ни один из этих пакетов не находится на PyPi (и никогда не будет). Пользователь выдает команду: pip -e git+https://github.com/Lewisham/cvsanaly@develop#egg=cvsanaly Этот репо имеет файл requirements.txt с другой зависимостью от […]

Python сократился после обновления OS X 10.8

Сделал обновление до Mac OS X 10.8 (Mountain Lion) и получил следующую ошибку при попытке вызвать $ pip : Traceback (most recent call last): File "/usr/local/bin/pip", line 5, in <module> from pkg_resources import load_entry_point File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 2603, in <module> working_set.require(__requires__) File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 666, in require needed = self.resolve(parse_requirements(requirements)) File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 565, in […]

Почему я не могу создать колесо в python?

Вот команды, которые я запускаю: $ python setup.py bdist_wheel usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] …] or: setup.py –help [cmd1 cmd2 …] or: setup.py –help-commands or: setup.py cmd –help error: invalid command 'bdist_wheel' $ pip –version pip 1.5.6 from /usr/local/lib/python3.4/site-packages (python 3.4) $ python -c "import setuptools; print(setuptools.__version__)" 2.1 $ python –version Python 3.4.1 […]

Как установить определенную версию пакета с помощью pip?

Возможный дубликат: Установка определенных версий пакета с помощью Pip Я немного новичок в pip install и virtualenv в целом. Я установил virtualenv на моем сервере, а также в локальной локальной среде. На сервере пакет django_modeltranslation-0.4.0_beta2 работает отлично. Однако на моей локальной машине django_modeltranslation-0.5.0-alpha , похоже, совсем не работает. Обычно я просто устанавливаю его в виртуальном […]

PyPI медленный. Как запустить собственный сервер?

Когда новый разработчик присоединяется к команде, или Jenkins запускает полную сборку, мне нужно создать новый virtualenv. Я часто нахожу, что настройка virtualenv с помощью Pip и большое количество (более 10) требований занимает очень много времени, чтобы установить все из PyPI. Часто это происходит в целом: Downloading/unpacking Django==1.4.5 (from -r requirements.pip (line 1)) Exception: Traceback (most […]

Как установить это колесо?

Мне удалось установить pip, но когда я использую pip для установки загруженного колеса, он печатает: C:\Python34\Scripts\pip install pygame-1.9.2a0-cp34-none-win_amd64.whl Requirement 'pygame-1.9.2a0-cp34-none-win_amd64.whl' looks like a filename, but the file does not exist pygame-1.9.2a0-cp34-none-win_amd64.whl is not a supported wheel on this platform Файл находится в той же папке (скрипты) с пипсом. Я тоже пытался использовать wheel инструмент: C:\Python34\Scripts\wheel […]

Python - лучший язык программирования в мире.