Ошибка импорта scipy.sparse

Мой питон 3.5.1 (32-разрядный) в Win7 (32-разрядный). Я установил 'scipy-0.16.1-cp35-none-win32.whl' и 'numpy-1.10.2 + mkl-cp35-none-win32.whl' загруженную форму http://www.lfd.uci.edu / ~ gohlke / pythonlibs / . И scipy модель может быть импортирована правильно, как показано ниже:

import scipy 

Но я получаю ошибки при импорте scipy.sparse:

 >>> import scipy.sparse Traceback (most recent call last): File "<stdin>", line 1, in <module> File "C:\Users\Administrator\AppData\Local\Programs\Python\Python35-32\lib\site-packages\scipy\sparse\__init__.py", line 213, in <module> from .csr import * File "C:\Users\Administrator\AppData\Local\Programs\Python\Python35-32\lib\site-packages\scipy\sparse\csr.py", line 13, in <module> from ._sparsetools import csr_tocsc, csr_tobsr, csr_count_blocks, \ ImportError: DLL load failed: The specified module could not be found. 

И я получил ошибку ниже, установив scipy by pip:

 pip install scipy 

 Command "c:\users\administrator\appdata\local\programs\python\python35-32\python.exe -c \ """import setuptools, tokenize; __file__='C:\\Users\\ADMINI~1\\AppData\\Local\\Temp\\pip-build-qzcp2rwj\\scipy\\s‌​etup.py'; exec(compile(getattr(tokenize, 'open', open)(file).read().replace('\r\n', '\n'), file, 'exec'))""" \ install --record C:\Users\ADMINI~1\AppData\Local\Temp\pip-lyz7f9x_-record\install-record.txt \ --single-version-externally-managed --compile" failed with error code 1 in C:\Users\ADMINI~1\AppData\Local\Temp\pip-build-qzcp2rwj\scipy 

Как правильно импортировать scipy.sparse?

Исправлена ​​ошибка, устанавливая зависимости python 3.4 и 3.4 от http://www.lfd.uci.edu/~gohlke/pythonlibs/ . Кажется, что ошибка воспроизводится только средой python 3.5.

Правильные конфигурации окружения:

  • ОС: Win7 (32-разрядная версия)
  • Python 3.4.3 (v3.4.3: 9b73f1c3e601, 24 февраля 2015, 22:43:06) [MSC v.1600 32 бит (Intel)] на win32
  • SciPy-0.17.0rc1-CP34-ни-win32.whl
  • NumPy-1.10.2 + MKL-CP34-ни-win32.whl