Состояние выхода Xcode gcc 1

Прежде всего, я очень новичок во всем этом.
Недавно я обновился до Snow Leopard и установил пакет разработчика Xcode + iPhone, 3.1.2. Я продолжил установку обработчика Django + MYSQLDB. Во время этапа сборки терминал показывает мне ошибку выхода 1 gcc. Но у меня уже установлен Xcode?

Где я иду не так?

Также, пытаясь исправить ситуацию, я установил Xcode, который появился с DVD Snow Leopard. по-прежнему такая же ошибка.

Теперь я думаю, что я должен полностью удалить Xcode и сделать новую установку?

Является ли ver.3.1.2 для 32-битного? Пожалуйста, помогите мне.

Вот полная ошибка:

Amit-Vermas-MacBook:mysql-python-1.2.2 amitverma$ gcc-4.0 i686-apple-darwin10-gcc-4.0.1: no input files Amit-Vermas-MacBook:mysql-python-1.2.2 amitverma$ python setup.py build running build running build_py copying MySQLdb/release.py -> build/lib.macosx-10.3-i386-2.5/MySQLdb running build_ext building '_mysql' extension gcc -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -fno-common -dynamic -DNDEBUG -g -O3 -Dversion_info=(1,2,2,'final',0) -D__version__=1.2.2 -I/usr/local/mysql/include -I/Library/Frameworks/Python.framework/Versions/2.5/include/python2.5 -c _mysql.c -o build/temp.macosx-10.3-i386-2.5/_mysql.o -g -Os -arch x86_64 -fno-common -D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DIGNORE_SIGHUP_SIGQUIT -DDONT_DECLARE_CXA_PURE_VIRTUAL cc1: error: unrecognized command line option "-Wno-long-double" error: command 'gcc' failed with exit status 1 

3 Solutions collect form web for “Состояние выхода Xcode gcc 1”

Я не уверен, решили ли вы свою проблему. Я получил ту же самую проблему после обновления с Mac OS 10.4 до 10.6.

После некоторых сообщений в блоге, в ожидании, я запустил setup.py, указав на более раннюю версию gcc (gcc-4.0).

CC = '/ usr / bin / gcc-4.0' python setup.py build

В сборке появилось несколько предупреждений.

 running build running build_py copying MySQLdb/release.py -> build/lib.macosx-10.3-i386-2.5/MySQLdb running build_ext building '_mysql' extension /usr/bin/gcc-4.0 -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -fno-common -dynamic -DNDEBUG -g -O3 -Dversion_info=(1,2,3,'gamma',1) -D__version__=1.2.3c1 -I/usr/local/mysql/include -I/Library/Frameworks/Python.framework/Versions/2.5/include/python2.5 -c _mysql.c -o build/temp.macosx-10.3-i386-2.5/_mysql.o -g -Os -arch i386 -fno-common -D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DIGNORE_SIGHUP_SIGQUIT -DDONT_DECLARE_CXA_PURE_VIRTUAL In file included from _mysql.c:36: /usr/local/mysql/include/my_config.h:1050:1: warning: "HAVE_WCSCOLL" redefined In file included from /Library/Frameworks/Python.framework/Versions/2.5/include/python2.5/Python.h:8, from pymemcompat.h:10, from _mysql.c:29: /Library/Frameworks/Python.framework/Versions/2.5/include/python2.5/pyconfig.h:724:1: warning: this is the location of the previous definition gcc -arch i386 -arch ppc -isysroot /Developer/SDKs/MacOSX10.4u.sdk -g -bundle -undefined dynamic_lookup build/temp.macosx-10.3-i386-2.5/_mysql.o -L/usr/local/mysql/lib -lmysqlclient_r -lz -lm -lmygcc -o build/lib.macosx-10.3-i386-2.5/_mysql.so ld: warning: in build/temp.macosx-10.3-i386-2.5/_mysql.o, file is not of required architecture ld: warning: in /usr/local/mysql/lib/libmysqlclient_r.dylib, file is not of required architecture ld: warning: in /usr/local/mysql/lib/libmygcc.a, file is not of required architecture 

Повторите ту же команду снова.

Все работает сейчас волшебно. Установка также прошла. Модуль работает так, как ожидалось.

Обычно это также показывает, почему компиляция терпит неудачу. Не могли бы вы дать текст, предшествующий «gcc, выходящий с кодом 1», или что-то в этом роде? И, возможно, и исходный файл.

Также найдите другие темы на эту тему, как этот . Хорошие условия поиска при переполнении google или стека – это леопард и MySQLdb.

Если это помогает, я решил эту проблему с символическими ссылками, и я думаю, что это сработает для вас. Я написал это с моей версией gcc, которая составляет 4.2:

 cd /usr/bin rm cc gcc c++ g++ ln -s gcc-4.2 cc ln -s gcc-4.2 gcc ln -s c++-4.2 c++ ln -s g++-4.2 g++ ln -s gcc-4.2 gcc-4.0 

Вот иди!

  • Событие отключения триггера в другом приложении в OSX
  • pycuda терпит неудачу; Теано с Анакондой
  • запустить простой скрипт python в ios
  • Установка PIL на OS X Snow Leopard с Xcode4 (без поддержки PPC)
  • Учебное пособие или руководство по созданию сценариев создания XCode
  • Не удается установить Lxml на Mac os x 10.9
  • xcrun / lipo зависает с OS X Mavericks и XCode 4.x
  • Добавить файлы в проект Xcode через командную строку? Использование файла project.pbxproj в Xcode?
  • MacOSX Инструменты для профилирования кода Python
  • Импортировать существующий проект python в XCode
  • ImportError: нет модуля с именем Foundation
  • Python - лучший язык программирования в мире.