'ImportError: нет модуля с именем pytz' при попытке импортировать pylab?

Насколько я могу судить, мне даже не нужно pytz для того, что я делаю.

Я переучиваю python для обработки изображений, используя книгу O'Reilly «Программирование компьютерного видения с Python» для работы (и я также новичок в mac, поэтому по обоим пунктам я извиняюсь, если это глупый вопрос). Наряду с изображением 'empire.jpg', я пытаюсь запустить сценарий на стр. 16, который выглядит следующим образом:

from PIL import Image from pylab import * # read image to array im = array(Image.open('empire.jpg')) # plot the image imshow(im) # some points x = [100,100,400,400] y = [200,500,200,500] # plot the points with red star-markers plot(x,y,'r*') # line plot connecting the first two points plot(x[:2],y[:2]) # add title and show the plot title('Plotting: "empire.jpg"') show() 

но я получаю следующий вывод с ошибкой:

  File "plotch1.py", line 2, in <module> from pylab import * File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/pylab.py", line 1, in <module> from matplotlib.pylab import * File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/matplotlib/pylab.py", line 208, in <module> from matplotlib import mpl # pulls in most modules File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/matplotlib/mpl.py", line 4, in <module> from matplotlib import axes File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/matplotlib/axes.py", line 18, in <module> from matplotlib import dates as mdates File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/matplotlib/dates.py", line 82, in <module> import pytz ImportError: No module named pytz 

Я использую OS X 10.9.4. Я установил matplotlib и numpy из macpython.org, и я установил scipy 0.11.0 для python 2.5.

Мне даже нужно pytz? Если нет, как мне обойти эту ошибку?

pylab требует pytz. Самый простой способ установить пакет в Python – запустить pip install pytz .

Сегодня Python поставляется с предустановленной пипой, но используйте эти инструкции, если вам нужно установить его: https://pip.pypa.io/en/latest/installing.html