Я не могу установить kivy в Anaconda Windows

Я пытаюсь установить kivy в Anaconda, но появилось следующее сообщение:

-(C:\ProgramData\Anaconda3) C:\Users\USER>conda install -c krisvanneste kivy=1.8.0 -Fetching package metadata ............... Solving package specifications: . UnsatisfiableError: The following specifications were found to be in conflict: - kivy 1.8.0* -> python 2.7* - python 3.6* Use "conda info <package>" to see the dependencies for each package. 

Что я делаю не так?

возможно, слишком поздно, но у меня была такая же проблема, просто следуйте инструкциям в документах (вместо этого используйте pip вместо conda)

  1. Убедитесь, что у вас есть последний пип и колесо:

    python -m pip install --upgrade pip wheel setuptools

  2. Установите зависимости (пропустите gstreamer (~ 120 МБ), если это не нужно, см. Зависимости Kivy):

    python -m pip install docutils pygments pypiwin32 kivy.deps.sdl2 kivy.deps.glew

    python -m pip install kivy.deps.gstreamer

Для Python 3.5 мы дополнительно предлагаем угол, который можно использовать вместо glew, и может быть установлен с:

 python -m pip install kivy.deps.angle 
  1. Установите kivy:

    python -m pip install kivy

На шаге 2 у меня была эта ошибка: PermissionError: [Errno 13] Permission denied:

Вам нужно перейти в папку Anaconda и отключить атрибут «Только для чтения», а затем снова запустить Шаг 2. Я не знаю, является ли это лучшим способом, но работает для меня.