Tag: pip

ImportError: Нет модуля с именем OpenSSL (python 2.7, windows 8.1)

Я установил pyOpenSSL и все необходимые пакеты, но я не могу импортировать OpenSSL в оболочку. Я получаю эту ошибку: >>> import OpenSSL Traceback (most recent call last): File "<stdin>", line 1, in <module> ImportError: No module named OpenSSL список необходимых пакетов, которые уже установлены: cryptography (0.9.3) distribute (0.7.3) idna (2.0) pip (7.1.0) pyasn1 (0.1.8) pyasn1-modules […]

Не удалось установить hyde с помощью pip в virtualenv в Windows

Так вот что я получаю, когда пытаюсь pip install hyde в virtualenv в Windows. Почему это происходит и как я могу это решить? C:\Users\s3z\Desktop\My Dropbox\Art_website>Scripts\activate (Art_website) C:\Users\s3z\Desktop\My Dropbox\3ambi_website>pip install hyde Downloading/unpacking hyde Downloading hyde-0.8.4.tar.gz (1.3Mb): 1.3Mb downloaded Running setup.py egg_info for package hyde Downloading/unpacking argparse (from hyde) Downloading argparse-1.2.1.tar.gz (69Kb): 69Kb downloaded Running setup.py egg_info […]

Как удалить неактивную версию пакетов, установленных с помощью easy_install

Я узнал, что у меня есть две версии pip установленные на моей OS X, и я бы хотел удалить старую версию (которая также обозначена как «неактивна» yolk -l ). В другом сообщении SO я обнаружил, что вы можете удалить пакет, используя команду pip uninstall . Но в моем случае я хотел бы удалить только старую […]

Ошибки, пытающиеся установить PySpotify

Я понимаю, что это, вероятно, слишком эзотерическое, чтобы получить здесь ответ, но я нахожусь в хакатоне и в отчаянии, поэтому стоит выстрелить … Я пытаюсь установить плагин PySpotify (https://github.com/mopidy/pyspotify), чтобы я мог использовать libspotify Spotify API для экспорта плейлистов в Spotify с веб-страницы. Направления в документации: 1) Установите libspotify с помощью homebrew (done) 2) Установите […]

Разработка с использованием пакетов с именами Python

У меня проблема с пакетами с именами на языке python, и мне интересно, что такое хорошее решение. Моя структура проекта похожа на следующую project_name/ext/app_ext Это проект, над которым я работаю. Он имеет зависимости, которые также находятся в одном и том же пространстве имен. project_name/ext/base_ext project_name/ext/other_dependency Я работаю над пакетом имен приложений «app_ext» в приложении django. […]

Путаница Python устанавливается в локальном пользователе (virtualenv, pip, distribute)

Я попытался установить python ниже. Но это не сработало. Возьмем «error: bad install directory или PYTHONPATH». Каков правильный способ установки pip, virtualenv и дистрибутива для Python? Сделать каталог $ mkdir -p ~/.python Добавить .bashrc #Use local python export PATH=$HOME/.python/bin:$PATH export PYTHONPATH=$HOME/.python Создать файл ~ / .pydistutils.cfg [install] prefix=~/.python Получить скрипт установки $ cd ~/src $ […]

Установка пачки не проверяет правильную ветку

Вот команда, которую я запускаю от марионетки: venv/bin/pip install -e git+https://blablabla.com/git/myproject.git@develop#egg=myproject Который должен установить ветку разработки. Вместо этого он не устанавливает ветви. Когда я перехожу в venv / src / myproject и делаю git branch, я вижу: ubuntu@ubuntu:/usr/service/myproject/venv/src/myproject$ git branch * (no branch) master Я использую Ubuntu 12.04 LTS. В чем может быть проблема?

Получение правильной зависимости в Heroku

Я пытаюсь заставить Heroku использовать редактируемую зависимость (т -e git://github.com/merlinares/django-registration.git#egg=django-registration ) с требованиями к -e git://github.com/merlinares/django-registration.git#egg=django-registration . Однако, хотя, по-видимому, он принимает эту вилку при развертывании, она фактически не использует ее. Я проверил код в сайтах-пакетах с heroku run cat .heroku/python/lib/python2.7/site-packages/registration/forms.py и он не включает новый код, но использует только стандартный django- который ранее был […]

pip + virtualenv: поврежденное состояние

Это похоже на поврежденное состояние. Во-первых, в virtualenv, pip freeze сообщает, что ipython установлен % workon myvenv (myvenv)% pip freeze | grep ipython ipython==0.12.1 … но ipython видимый изнутри virtualenv, не тот, который установлен под virtualenv: (myvenv)% which ipython /usr/bin/ipython Действительно, если вы попытаетесь «удалить» копию ipython, установленную под virtualenv, pip откажется: (myvenv)% pip uninstall […]

Устранение неполадок PyObjc с помощью pip, easy_install, manual

У меня возникли проблемы с установкой PyObjC. Я пробовал pip, easy_install и ручную установку, и все они дают мне ошибки. Я пытаюсь использовать easy_install прямо сейчас, потому что это рекомендуется с сайта PyObjC. Для запуска я использую команду: sudo env CC=clang easy_install -U pyobjc-core Я получаю следующие предупреждения: warning: no directories found matching 'Scripts' warning: […]

Python - лучший язык программирования в мире.